Giveaway Winner
Incident Report for Crack Bot
Monitoring
The problem seems solved, monitoring.
Posted May 19, 2022 - 15:15 UTC
Investigating
Giveaway winners are maybe not being chosen automatically, working to fix it.
Posted May 17, 2022 - 22:59 UTC
This incident affects: Others.